Curve Mobile App Unavailability
Incident Report for Curve
Resolved
This incident has been resolved. We apologise for any inconvenience.
Posted Sep 22, 2024 - 21:05 UTC
Monitoring
Our third party has implemented a fix and we are now seeing normal activity. We will continue to monitor.
Posted Sep 22, 2024 - 20:52 UTC
Identified
We have identified an issue with one of our third parties and are working closely with them to resolve it.
Posted Sep 22, 2024 - 20:32 UTC
Investigating
We are aware of problems interacting with the Curve Mobile app on both iOS and Android. We are investigating.
Posted Sep 22, 2024 - 20:29 UTC
This incident affected: In-app Curve functionality.