Issues processing transactions
Incident Report for Curve
Resolved
This incident has been resolved. We apologize for any inconvenience this will have caused.
Posted Sep 18, 2022 - 12:49 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 18, 2022 - 11:51 UTC
Identified
We’re aware of some issues affecting payment processing at the moment. We’re already looking into it but, we’re sorry to say, some of your purchases may get declined in the meantime.
Posted Sep 18, 2022 - 11:03 UTC
This incident affected: Transactions processing.