Increased Transaction Declines

Incident Report for Curve

Resolved

We have identified the issue related to a recent change and have applied a fix. Transaction success rates have now stabilised, and we are monitoring to ensure continued normal operation.
Posted Mar 26, 2026 - 23:39 UTC

Investigating

We are currently investigating an issue causing an increase in declined transactions. Our engineering team is actively working to identify the root cause and assess the impact.

We will provide further updates as soon as more information becomes available.
Posted Mar 26, 2026 - 22:25 UTC
This incident affected: Transactions processing.