Mastercard's service has been restored and we're seeing things return to normal. We'll continue monitoring closely until we can confirm full resolution.
Posted Sep 03, 2026 - 21:46 UTC
Update
Mastercard's service has been restored and we're seeing things return to normal. We'll continue monitoring closely until we can confirm full resolution.
Posted Sep 03, 2026 - 21:45 UTC
Update
This issue is still ongoing and we don't yet have a resolution. We appreciate your patience and will share more as soon as we have an update.
Posted Sep 03, 2026 - 17:31 UTC
Update
This is due to an issue with Mastercard's APIs, which we depend on for processing, and may be impacting some in-app functionality. We'll share more as soon as we have an update.
Posted Sep 03, 2026 - 15:12 UTC
Identified
We've identified the issue as being caused by a third-party API we depend on. There is no fix yet, but we are actively working with the third-party provider to resolve this as quickly as possible. We'll share more as soon as we have an update.
Posted Sep 03, 2026 - 14:54 UTC
Investigating
We’re aware of some issues affecting payment processing at the moment. We’re already looking into it but, we’re sorry to say, some of your purchases may get declined in the meantime.
Posted Sep 03, 2026 - 14:39 UTC
This incident affects: Transactions processing, In-app Curve functionality, and Mobile wallet and wearables (Apple Pay, Google Pay, Samsung Pay, etc).