Issues processing transactions

Incident Report for Curve

Resolved

This incident has been resolved.
Posted Apr 17, 2023 - 10:03 UTC

Monitoring

Service functionality has recovered and we're monitoring it.
Posted Apr 17, 2023 - 09:56 UTC

Identified

Heads up! We’re experiencing service issues at the moment. We’re already on it, but you might be getting declines. We’re really sorry: stay tuned for updates.
Posted Apr 17, 2023 - 09:44 UTC
This incident affected: Transactions processing.