Issue identified on adding card to the wallet

Incident Report for Curve

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 17:54 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2026 - 17:47 UTC

Investigating

We are currently experiencing an issue with our third-party service provider, and as a result, customers are unable to add their cards to a digital wallet at this time. The provider is working to resolve the issue as quickly as possible.

Our team is actively monitoring the situation in coordination with the provider and will share updates as soon as more information becomes available. Thank you for your patience.
Posted Apr 27, 2026 - 17:29 UTC
This incident affected: Mobile wallet and wearables (Apple Pay, Google Pay, Samsung Pay, etc).