We are monitoring a return of traffic to our online transactions. We apologise on behalf of our third-party partners for this unplanned maintenance window, and appreciate your understanding. Happy spending!
Posted Nov 10, 2024 - 02:47 UTC
Monitoring
An update from our partner causing this downtime:
"We expect a maximum of 90 minutes of downtime during this maintenance window, all calls to the 3DS services will receive a status “U” during this period. Our operations team will closely monitor service performance before, during, and after this maintenance period."
Posted Nov 10, 2024 - 02:40 UTC
Identified
One of our partners has needed to carry out essential unplanned maintenance on Sunday, 10rd November 2024 between 02:00 AM GMT and 04:00 AM GMT. This means some Curve functionality might be temporarily unavailable within that timeframe. Apologies for the inconvenience. Please carry a backup card with you during that time.