Issue processing transactions
Incident Report for Curve
Resolved
Between 05:55 and 08:15 BST, we experienced a disruption to our service, which caused some of our customers to receive declines when making payments. This issue has now be resolved and we are now processing transactions as normal. We apologise for the inconvenience caused.
Posted Apr 24, 2019 - 07:42 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 24, 2019 - 07:41 UTC
Identified
The issue has been identified and a fix is being implemented
Posted Apr 24, 2019 - 07:38 UTC
Investigating
We are currently experiencing issues with processing transactions. We recommend that you carry a backup card during this time.

We’re sorry about the inconvenience and will let you know as soon as the issue has been resolved.
Posted Apr 24, 2019 - 07:36 UTC
This incident affected: Transactions processing.