Identity verification service disruption — onboarding and step-up checks impacted

Incident Report for Curve

Resolved

Our upstream identity verification provider has completed their remediation work and restored normal service. We are now observing healthy performance across our onboarding and step-up verification flows (document upload, selfie, and motion/liveness verification).

Thanks for your patience while this issue was being addressed.
Posted Jan 07, 2026 - 16:39 UTC

Monitoring

Our upstream identity verification provider is reporting signs of recovery, and we are also seeing improved performance in our onboarding and step-up verification flows (document upload, selfie, and motion/liveness verification).

While the provider’s systems appear to be stabilising, we are continuing to monitor the situation closely before marking the incident as resolved, to ensure the service remains reliable for all users.

A small number of verification attempts may still experience intermittent issues during this recovery period. We will share further updates as we gain confidence in full stability.

Thank you for your patience and understanding.
Posted Jan 07, 2026 - 16:08 UTC

Identified

We are currently experiencing an issue with our identity verification workflow. As a result, new customer onboarding and step-up verification checks (including document upload, selfie, and motion/liveness verification) may fail or be unavailable. Existing accounts and other platform features remain unaffected.

The disruption is related to an upstream identity verification dependency, and we are actively working with the partner involved to restore normal service. We will provide updates here as soon as we have more information.

Thank you for your patience while we work to resolve this.
Posted Jan 07, 2026 - 15:15 UTC
This incident affected: In-app Curve functionality.