Some customers may be experiencing declines
Incident Report for Curve
Resolved
This incident has been resolved.
Posted Dec 25, 2019 - 17:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 25, 2019 - 16:36 UTC
Identified
We are currently experiencing intermittent issues with processing transactions, meaning some customers may experience a decline when attempting to make a payment. We understand that this is frustrating and we’re sorry about the inconvenience. There may also be some issues with app functionality at this time.

We will let you know as soon as the issue has been fixed. We recommend that you carry a backup card during this time.
Posted Dec 25, 2019 - 16:28 UTC
This incident affected: Transactions processing and In-app Curve tools.