Issues processing transactions

Incident Report for Curve

Resolved

PayPal transactions are now fully operational. The issue has been resolved, and we sincerely apologize for any inconvenience this may have caused.
Posted Oct 16, 2025 - 17:54 UTC

Monitoring

Transaction processing for PayPal payments is now back to normal. We’ll continue to monitor closely to ensure everything remains stable.
Posted Oct 16, 2025 - 16:53 UTC

Update

We’re continuing to work closely with our third-party provider, PayPal, to resolve the ongoing API issues. We’re sorry to say that some PayPal transactions may still be declined, but we’ll keep monitoring and share updates until the issue is fully resolved.
Posted Oct 16, 2025 - 16:13 UTC

Identified

PayPal’s API is currently experiencing issues. We’re in contact with their team, but some PayPal payments may still be declined. Other payment methods are unaffected. We’ll keep you updated as we learn more.
Posted Oct 16, 2025 - 15:39 UTC

Investigating

We are currently experiencing degraded transaction processing for payments made using customers’ PayPal accounts. Other payment methods are not affected. We’re already looking into it but, we’re sorry to say, some of your purchases may get declined in the meantime.
Posted Oct 16, 2025 - 15:23 UTC
This incident affected: Transactions processing.