Issue processing transaction using Discover & Diners.

Incident Report for Curve

Investigating

We are currently aware of an issue affecting payments made with Discover and Diners Club cards. Some customers may experience transaction declines when using these card types.

This is related to an ongoing issue with one of our payment processing partners and we are actively working with them to resolve it as quickly as possible.

We apologise for any inconvenience this may cause. In the meantime, we recommend using an alternative card if available.

We will provide further updates as the situation develops.
Posted Sep 06, 2026 - 20:59 UTC
This incident affects: Transactions processing and Mobile wallet and wearables (Apple Pay, Google Pay, Samsung Pay, etc).