Payment Processing Degradation

Incident Report for Curve

Resolved

The issue has been resolved, and we apologize for any inconvenience this may have caused.
Posted Jul 19, 2025 - 20:12 UTC

Monitoring

We are seeing improvements in both transaction declines and latency. We continue to monitor the situation closely.
Posted Jul 19, 2025 - 19:30 UTC

Update

We are continuing to monitor the issue, but there are no new updates at this time. We will share further information as soon as it becomes available.
Posted Jul 19, 2025 - 18:19 UTC

Update

We have identified that the service degradation is caused by elevated latency from a payment scheme, which is leading to intermittent transaction declines.
We’ll provide updates as soon as more information becomes available.
Posted Jul 19, 2025 - 17:15 UTC

Identified

We’re currently experiencing service degradation due to elevated latency from our payment acquirers. As a result, some transactions may be declined or delayed.
Our team is actively monitoring the situation and working with our partners to resolve the issue as quickly as possible. We sincerely apologize for the inconvenience and appreciate your patience.
We’ll provide updates as soon as more information becomes available.
Posted Jul 19, 2025 - 16:31 UTC
This incident affected: Transactions processing and Mobile wallet and wearables (Apple Pay, Google Pay, Samsung Pay, etc).