"Hi" (Moorwand Ltd) declines
Incident Report for Curve
Resolved
We have been monitoring transactions done on the BINs 520581 and 516921 and we are glad to see that in the past week, payments on these BINs are being approved in a timely manner again. We apologize again for the inconvenience this issue might have caused to you.
Posted Aug 10, 2023 - 16:52 UTC
Update
We have reduced the number of declines that our customers are experiencing using funding cards starting with 520581 (Moorwand Ltd) but continue to monitor and work with Moorwand to eliminate the issue. Further updates expected soon.
Posted May 25, 2023 - 09:18 UTC
Investigating
We are investigating an issue affecting Curve customers that have linked a "Hi" (Moorwand Ltd) funding card to their wallet, where some transactions are being declined. Rest assured that you will be refunded if you have been charged incorrectly.
Posted May 22, 2023 - 16:25 UTC
This incident affected: Transactions processing.