Issues Processing Transactions

Incident Report for Curve

Resolved

The latency is still high with our third party payment processors, but they have been able to process payments for a prolonged period now. Apologies for any inconvenience this may have caused.
Posted Aug 01, 2024 - 14:29 UTC

Monitoring

We are observing a return to normal of our latency with our third party payment processor. We will continue to monitor the situation. Apologies to any customers affected by this.
Posted Aug 01, 2024 - 12:25 UTC

Identified

A thirdparty Payment Processor is experiencing increased latency. This is affecting our ability to process payments. We are working closely with our Payment Processor to resolve this issue. Apologies for any inconvenience this maybe causing.
Posted Aug 01, 2024 - 11:17 UTC

Investigating

We’re aware of some issues affecting payment processing at the moment. We’re already looking into this. We are sorry to say, some of your online and in-store purchases may get declined in the meantime. We apologise for any inconvenience this will cause you.
Posted Aug 01, 2024 - 11:16 UTC
This incident affected: Transactions processing.