Some customers may be experiencing declines
Incident Report for Curve
Resolved
This incident has been identified and resolved.
Posted Jan 14, 2020 - 15:15 UTC
Update
We are continuing to investigate this issue.
Posted Jan 14, 2020 - 15:11 UTC
Investigating
We are currently experiencing intermittent issues with processing transactions, meaning some customers may experience a decline when attempting to make a payment. We understand that this is frustrating and we’re sorry about the inconvenience.

We will let you know as soon as the issue has been fixed. We recommend that you carry a backup card during this time.
Posted Jan 14, 2020 - 15:07 UTC
This incident affected: Transactions processing.