Issues processing transactions

Incident Report for Curve

Resolved

This incident is now resolved. We apologize for the inconvenience this may have caused and appreciate your patience while we worked with our provider to restore service.
Posted Oct 02, 2025 - 18:26 UTC

Monitoring

Card addition is now working normally. We’ll continue monitoring to ensure everything stays stable.
Posted Oct 02, 2025 - 18:07 UTC

Update

Transaction processing has improved and is operating normally. However, we are still experiencing issues with adding cards to Curve's wallet. Our team is actively working with the third-party provider to resolve this. We will continue to share updates as more information becomes available.
Posted Oct 02, 2025 - 17:21 UTC

Identified

We have identified a third-party service issue that may be affecting transaction processing and card addition to wallet. We are monitoring the situation closely and are in contact with the provider to ensure this is resolved. Updates will be shared here as soon as more information becomes available.
Posted Oct 02, 2025 - 17:10 UTC
This incident affected: Transactions processing and In-app Curve functionality.