Service disruption
Incident Report for Curve
Resolved
We believe the incident to be resolved and service has fully been restored to both Curve app and using Curve for payments.
Posted Jan 30, 2021 - 20:01 UTC
Monitoring
We believe the issues using Curve for payments or accessing the Curve app have been resolved but we are continuing to monitor before we will consider the incident resolved.
Posted Jan 30, 2021 - 19:44 UTC
Identified
We are aware some customers may be having issues making payments with Curve, or with accessing features in the app. We have identified the cause and are working to resolve it as quickly as possible.
Posted Jan 30, 2021 - 19:16 UTC
This incident affected: Transactions processing, In-app Curve functionality, and Mobile wallet and wearables (Apple Pay, Google Pay, Samsung Pay, etc).