Issues processing FX transactions
Incident Report for Curve
Resolved
This incident has been resolved.
Posted Mar 09, 2024 - 03:54 UTC
Update
We are continuing to investigate this issue.
Posted Mar 08, 2024 - 23:34 UTC
Investigating
We're aware of some issues affecting FX transactions, involving specific currencies. We are working with our third-party service provider to resolve this. We are sorry to say that in the meantime, some of your purchases may get declined. We apologise for any inconvenience this will cause you.
Posted Mar 08, 2024 - 23:33 UTC
This incident affected: Transactions processing.