Payment Processing Degradation

Incident Report for Curve

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 15:50 UTC

Monitoring

We have identified that the earlier service degradation was caused by elevated latency from a payment scheme, which led to intermittent transaction declines.
We are now seeing signs of improvement, and transaction success rates are stabilizing. However, we are continuing to closely monitor the situation to ensure full resolution.
Posted Jul 10, 2025 - 13:49 UTC

Identified

We’re currently experiencing service degradation due to elevated latency from our payment schemes. As a result, some transactions may be declined or delayed.
Our team is actively monitoring the situation and working with our partners to resolve the issue as quickly as possible. We sincerely apologize for the inconvenience and appreciate your patience.
We’ll provide updates as soon as more information becomes available.
Posted Jul 10, 2025 - 08:39 UTC
This incident affected: Transactions processing.