Issues processing transactions
Incident Report for Curve
Resolved
This incident has now been resolved. We apologise again for all the inconvenience we have caused you.
Posted Feb 22, 2024 - 11:48 UTC
Identified
One of our partners has identified the issue and we are monitoring the fix.
Posted Feb 22, 2024 - 09:40 UTC
Investigating
We’re aware of some issues affecting the online payment processing at the moment. We’re already looking into this. We are sorry to say, some of your online purchases may get declined in the meantime. We apologise for any inconvenience this will cause you.
Posted Feb 22, 2024 - 09:39 UTC
This incident affected: Transactions processing and Mobile wallet and wearables (Apple Pay, Google Pay, Samsung Pay, etc).