Some customers are experiencing declines
Incident Report for Curve
Resolved
This incident has been resolved.
Posted Sep 07, 2020 - 12:53 UTC
Investigating
We are currently experiencing intermittent issues with processing transactions, meaning some customers may experience a decline when attempting to make a payment. We are also experiencing issues with our in-app tools, including Curve Send. We understand that this is frustrating and we’re sorry about the inconvenience.

We will let you know as soon as the issue has been fixed. We recommend that you carry a backup card during this time.
Posted Sep 07, 2020 - 11:54 UTC
This incident affected: Transactions processing, In-app Curve functionality, and Mobile wallet and wearables (Apple Pay, Google Pay, Samsung Pay, etc).