This incident is now resolved and all services are operating normally. Thank you for your patience, and we're sorry for the disruption.
Posted Jul 15, 2026 - 10:12 UTC
Monitoring
Mastercard has implemented a fix, and we're seeing service begin to return to normal. We'll continue monitoring closely and confirm once fully resolved.
Posted Jul 15, 2026 - 09:20 UTC
Update
We're still monitoring this issue closely. No new updates to share yet, but we'll post here as soon as there's progress.
Posted Jul 15, 2026 - 09:00 UTC
Update
The payment issues are traced to Mastercard's servers and their team is working on a fix, not yet resolved. We'll update as soon as it's restored.
Posted Jul 15, 2026 - 08:24 UTC
Identified
We are currently experiencing a significant disruption affecting transactions that require 3D Secure (3DS) challenges due to an issue with a third-party provider. As a result, a high number of these transactions may be declined during the authentication process.
Our team is working closely with the provider to restore normal approval rates and is actively monitoring the situation. We will provide further updates as more information becomes available.