Issues processing transactions
Incident Report for Curve
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 19:00 UTC
Monitoring
The issue processing payments has been resolved. We are now monitoring.
Posted Jul 25, 2024 - 18:47 UTC
Investigating
We’re aware of some issues affecting payment processing at the moment. We’re already looking into this. We are sorry to say, some of your online and in-store purchases may get declined in the meantime. We apologise for any inconvenience this will cause you.
Posted Jul 25, 2024 - 18:37 UTC
This incident affected: Transactions processing and Mobile wallet and wearables (Apple Pay, Google Pay, Samsung Pay, etc).