Issues with Curve app

Incident Report for Curve

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 07:30 UTC

Update

The issue has been resolved, and we apologize for any inconvenience this may have caused.
Posted Aug 12, 2025 - 07:29 UTC

Update

The issue was identified in the communication between Curve and a thrid-party. We are working on a fix.
Posted Aug 12, 2025 - 07:06 UTC

Investigating

We’ve noticed some customers may have issues while accessing the Curve app. We’re looking into it and are sorry for any inconvenience it’s causing.
Posted Aug 12, 2025 - 06:56 UTC
This incident affected: In-app Curve functionality.