Issues with Cashback
Incident Report for Curve
Resolved
This incident has now been resolved. We apologize again for all the inconvenience we have caused you.
Posted Feb 27, 2024 - 11:01 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 24, 2024 - 07:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results. This will not affect any new customers and any new upgrades or Premium customers. Few customers could still be affected and we continue to check this. We apologise again for all the inconvenience this have caused you.
Posted Feb 23, 2024 - 19:15 UTC
Investigating
We are currently investigating an issue affecting Cashback retailer selection on upgrade to Black and Metal tiers. We apologise for any inconvenience this will cause you.
Posted Feb 23, 2024 - 18:30 UTC
This incident affected: In-app Curve functionality.