Major Outage For All Cardholders
Incident Report for Curve
Resolved
This incident has been resolved.
Posted Jul 16, 2020 - 10:33 UTC
Update
As of Monday 29 June, payments with your Curve card have been re-enabled. For further information please visit our blog post here: https://discover.curve.app/a/wirecard-whats-happened-what-it-means-and-how-were-fixing-it
Posted Jul 02, 2020 - 11:04 UTC
Update
As of Monday 29 June, payments with your Curve card have been re-enabled. For further information please visit our blog post here: https://discover.curve.app/a/wirecard-whats-happened-what-it-means-and-how-were-fixing-it
Posted Jun 30, 2020 - 14:06 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 30, 2020 - 14:01 UTC
Update
As of Monday 29 June, payments with your physical Curve card have been re-enabled. For further information please visit our blog post here: https://discover.curve.app/a/wirecard-whats-happened-what-it-means-and-how-were-fixing-it
Posted Jun 29, 2020 - 08:22 UTC
Update
As of Monday 29 June, payments with your Curve card have been re-enabled. For further information please visit our blog post here: https://discover.curve.app/a/wirecard-whats-happened-what-it-means-and-how-were-fixing-it
Posted Jun 29, 2020 - 08:13 UTC
Monitoring
Following the effective shutdown of Wirecard Card Solutions Limited by the FCA, Curve services are temporarily suspended. We'll be back shortly but in the meantime please use an alternative payment method.
Posted Jun 26, 2020 - 14:26 UTC
This incident affected: Transactions processing, Mobile wallet and wearables (Apple Pay, Google Pay, Samsung Pay, etc), Curve Send, and In-app Curve tools.