Issues processing transactions

Incident Report for Curve

Resolved

This incident has been resolved. We apologise for any inconvenience this might have caused.
Posted Feb 03, 2023 - 20:19 UTC

Monitoring

Service functionality has recovered and we're monitoring it.
Posted Feb 03, 2023 - 19:35 UTC

Investigating

Heads up! We’re experiencing service issues at the moment. We’re already on it, but you might be getting declines or be unable to access the Curve app for now. We’re really sorry: stay tuned for updates.
Posted Feb 03, 2023 - 19:10 UTC
This incident affected: Transactions processing and Mobile wallet and wearables (Apple Pay, Google Pay, Samsung Pay, etc).