Doc&Selfie screen experiencing issues on Android devices running version 4.11.0 or higher
Incident Report for Curve
Resolved
Doc&Selfie issue was fixed on Android version 4.12.1. All new customers will now be able to sign up for Curve. We're sorry for any inconvenience.
Posted Nov 11, 2023 - 13:38 UTC
Investigating
We’re aware of an issue affecting our Doc&Selfie functionality. We’re already looking into it.
Apology for any inconvenience this will cause you.
Posted Nov 10, 2023 - 12:24 UTC
This incident affected: In-app Curve functionality.