Issues Processing Transactions

Incident Report for Curve

Resolved

We have observed no further issues with our payment processor. Happy spending!
Posted Aug 01, 2024 - 10:09 UTC

Monitoring

Our thirdparty Payment Processor has deployed a fix and we are monitoring the latency which returned to normal at 10:35am BST. We apologise for any inconvenience this may have caused.
Posted Aug 01, 2024 - 09:44 UTC

Identified

Our thirdparty payment processor is experiencing high latency in processing some of our transactions. We are working closely with them to resolve this issue.
Posted Aug 01, 2024 - 09:32 UTC

Investigating

We’re aware of some issues affecting payment processing at the moment. We’re already looking into this. We are sorry to say, some of your online and in-store purchases may get declined in the meantime. We apologise for any inconvenience this will cause you.
Posted Aug 01, 2024 - 09:31 UTC
This incident affected: Transactions processing.