Issues with incoming 3DS challenge on payment journey

Incident Report for Curve

Resolved

This incident has been resolved.
Posted May 28, 2025 - 12:42 UTC

Monitoring

This incident has now been resolved.
Posted May 28, 2025 - 13:15 UTC

Investigating

We are aware of issues processing transactions that require 3DS authentication.

We are looking into the problem, but we're sorry to say, that some of your purchases may be declined in the meantime.
Posted May 28, 2025 - 12:10 UTC
This incident affected: Transactions processing.