Issues processing transactions
Incident Report for Curve
Resolved
This incident has now been resolved. We apologise again for all the inconvenience we have caused you.
Posted Feb 11, 2024 - 16:06 UTC
Monitoring
One of our partners has had technical issues which affected our transaction processing platform. We have applied some mitigation measures and seeing that it is improving. We will keep you up to date.
Posted Feb 11, 2024 - 15:54 UTC
Investigating
We’re aware of some issues affecting payment processing at the moment. We’re already looking into this. We are sorry to say, some of your purchases may get declined in the meantime. We apologise for any inconvenience this will cause you.
Posted Feb 11, 2024 - 14:40 UTC
This incident affected: Transactions processing and Mobile wallet and wearables (Apple Pay, Google Pay, Samsung Pay, etc).