Issues processing transactions
Incident Report for Curve
Resolved
This incident has now been resolved. We apologise again for all the inconvenience we have caused you.
Posted Dec 16, 2023 - 04:33 UTC
Monitoring
One of our partners has had technical issues which affected our transaction processing platform. We are observing the situation and seeing that it is improving. We will keep you up to date.
Posted Dec 15, 2023 - 23:57 UTC
Investigating
We’re aware of some issues affecting payment processing at the moment. We’re already looking into it but, we’re sorry to say, some of your purchases may get declined in the meantime.
Posted Dec 15, 2023 - 23:05 UTC
This incident affected: Transactions processing.