FX Processing Degradation

Incident Report for Curve

Resolved

Our FX provider’s API has remained healthy and FX processing continues to operate as expected.

We’re now considering this incident resolved.
Posted Sep 04, 2026 - 23:36 UTC

Monitoring

Our FX provider is back online and responding normally. FX processing has been restored and transactions are operating as expected.

We’ll continue to closely monitor the service to ensure it remains stable.
Posted Sep 04, 2026 - 22:36 UTC

Investigating

We are currently experiencing issues with our FX rate provider, which may impact some transactions requiring currency conversion.

Our team is actively investigating and working to restore normal service. We’ll provide further updates as they become available.
Posted Sep 04, 2026 - 21:41 UTC
This incident affected: Transactions processing.