3DS challenges approval rate degraded

Incident Report for Curve

Resolved

This incident has been resolved
Posted Aug 22, 2025 - 17:54 UTC

Monitoring

Our vendor has confirmed, they implemented the fix and we are currently monitoring its performance.
Posted Aug 22, 2025 - 15:58 UTC

Identified

We are currently experiencing reduced approval rates for transactions requiring 3D Secure (3DS) challenges due to an issue with a third-party provider. This may result in more transactions than usual being declined during authentication.

Our team is actively monitoring the situation together with the provider and will provide updates as soon as more information becomes available.
Posted Aug 22, 2025 - 15:31 UTC
This incident affected: Transactions processing.