Issues processing transactions
Incident Report for Curve
Resolved
One of our partners had some technical issues which affected our transaction processing platform.
Our service has now been fully restored (from around 11:10 GMT).
We apologize again for any inconvenience this might have caused you.
Posted Dec 07, 2023 - 12:55 UTC
Update
One of our partners has identified the issue and we are monitoring the fix.
Posted Dec 07, 2023 - 12:01 UTC
Investigating
We’re aware of some issues affecting payment processing at the moment. We’re already looking into this. We are sorry to say, some of your purchases may get declined in the meantime. We apologise for any inconvenience this will cause you.
Posted Dec 07, 2023 - 10:39 UTC
This incident affected: Transactions processing and Mobile wallet and wearables (Apple Pay, Google Pay, Samsung Pay, etc).