Issues processing transactions
Incident Report for Curve
Resolved
One of our partners has had technical issues which affected our transaction processing platform.
Our service has now been fully restored (from around 14:54 GMT).
We apologize again for any inconvenience this might have caused you.
Posted Nov 02, 2023 - 15:09 UTC
Investigating
We’re aware of some issues affecting payment processing at the moment. We’re already looking into it but, we’re sorry to say, some of your purchases may get declined in the meantime. We apologise for any inconvenience this will cause you.
Posted Nov 02, 2023 - 14:45 UTC
This incident affected: Transactions processing.