3DS challenge approval rate degraded

Incident Report for Curve

Monitoring

Payment processing is now operating normally. We'll continue monitoring our systems closely to ensure everything remains stable.

Thank you for your patience while we worked through this.
Posted Jul 16, 2026 - 16:18 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 16, 2026 - 09:18 UTC

Update

Our team is working closely with the provider to restore normal approval rates and is actively monitoring the situation. We will provide further updates as more information becomes available.
Posted Jul 16, 2026 - 09:07 UTC

Identified

We are currently experiencing limited disruption for some transactions that require 3D Secure (3DS) challenges due to an issue with a third-party provider. As a result, a limited number of these transactions may be declined during the authentication process.

Our team is working closely with the provider to restore normal approval rates and is actively monitoring the situation. We will provide further updates as more information becomes available.
Posted Jul 16, 2026 - 09:01 UTC
This incident affects: Transactions processing.