Issues Processing PayPal Transactions

Incident Report for Curve

Resolved

We have observed a return of service for our PayPal transactions. We apologies for any inconvenience this may have caused.
Posted May 15, 2025 - 15:42 UTC

Monitoring

PayPal are currently experiencing service disruptions on their payment flow. You can follow PayPal's service disruptions here: https://www.paypal-status.com/product/production. We will continue to monitor and keep you updated
Posted May 15, 2025 - 14:29 UTC
This incident affected: Transactions processing.