Some customers may be experiencing declines
Incident Report for Curve
Resolved
We experienced a disruption to our service today which caused some of our customers to receive declines when making payments and have issues using some features in the Curve app. This issue has now been fixed and transactions are being processed as normal. We're very sorry for the inconvenience caused.
Posted Aug 17, 2019 - 13:26 UTC
Monitoring
A fix has been implemented for this issue and we are monitoring the results. We're very sorry for any inconvenience caused and will update you again as soon as possible.
Posted Aug 17, 2019 - 12:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 17, 2019 - 11:47 UTC
Update
We are continuing to investigate this issue.
Posted Aug 17, 2019 - 09:57 UTC
Investigating
We are currently experiencing intermittent issues with processing transactions, meaning some customers may experience a decline when attempting to make a payment. We understand that this is frustrating and we’re sorry about the inconvenience.

We will let you know as soon as the issue has been fixed. We recommend that you carry a backup card during this time.
Posted Aug 17, 2019 - 09:42 UTC
This incident affected: Transactions processing and Mobile apps (iOS and Android).