Issues processing transactions
Incident Report for Curve
Resolved
This incident has been resolved. We apologize for any inconvenience this will have caused.
Posted Sep 23, 2022 - 18:30 UTC
Monitoring
We are processing payments again and currently monitoring our systems.
Posted Sep 23, 2022 - 16:55 UTC
Update
We are continuing to investigate this issue.
Posted Sep 23, 2022 - 16:38 UTC
Investigating
We’re aware of some issues affecting payment processing at the moment. We’re already looking into it but, we’re sorry to say, some of your purchases may get declined in the meantime.
Posted Sep 23, 2022 - 16:31 UTC
This incident affected: Transactions processing.