Payment processing disruption
Incident Report for Curve
Resolved
The incident is resolved - payments are processing correctly and the Curve app is working as usual.
Posted Mar 02, 2021 - 23:19 UTC
Monitoring
Payments made with Curve should now be successful, and we're continuing to monitor before we consider the issue fully resolved.
Posted Mar 02, 2021 - 22:58 UTC
Investigating
We are investigating an issue affecting processing of payments with Curve. Payments might not succeed at this time until the issue is resolved.
Posted Mar 02, 2021 - 22:43 UTC
This incident affected: Transactions processing, Mobile wallet and wearables (Apple Pay, Google Pay, Samsung Pay, etc), Curve Send, and In-app Curve tools.